Dienstag, 21. April 2009

Longer time without update again

Again two months passed by without real news from me. On the Xvid-side, nothing happened for some time - so there is no need for a new build. The work is taking up plenty of time of course, as usual. So there is no time for playing around with code.

Anyhow, I'm still alive. Should there something happen like a new Xvid release, I'll be right there. Since I don't have a 64 Bit Windows and according build system around, I still can't provide a 64 Bits build. It's nice that you ask for it though!

Kommentare:

Joe Redfish hat gesagt…

xvid 1.2.2 ist raus. Hab schon mal durchkompiliert (VC6). Sieht gut aus.

Anonym hat gesagt…

Hi Koepi

I have a Vista x64 system and installed your latest v1.2.1 VAQ build but the thing is that the encoder/decoder setting windows cant be opened. The error messages i get is that it cant read xvid.ax and xvidvfw.dll (or something similar to that).

I have tested 2 other xvid x86 builds and on those so does the setting windows work just fine.

So I really hope that this is something you could fix when you make your new v1.2.2 builds available. ;)

Max hat gesagt…

Habe eine kleine Anleitung in meinem Blog hinterlegt, die Einsteigern bei der XVID-Compilierung unter Windows mit Visual Studio helfen könnte.

Die Anleitung findet sich hier:
- Teil 1: Core und VFW-Treiber - Teil 2: DirectShow-TreiberDie Basics sollten damit machbar sein. Feedback über weitere Möglichkeiten, z.B. plattformspezifische Optimierungsmöglichkeiten sind natürlich gerne willkommen.

Koepi hat gesagt…

I didn't have any time yet to compile a new xvid build. I hope to manage that the coming weekend.

As for x64 setups, I have no system to test the installer if it works correctly. Sorry!

Anonym hat gesagt…

Hi, the Xvid page (http://www.koepi.info/xvid.html) doesn't have a link to the 1.2.2 version.

Anonym hat gesagt…

I would like to have a choice whether to install XVID VfW and DirectShow Filter to play XVID videos. Plan you add this options in to installer?

Koepi hat gesagt…

The graphic "download" right on the top of the xvid page links to 1.2.2...

Anonym hat gesagt…

Hi Koepi

Thought that i would let ya know that in ur latest v1.2.2 rls so does the encoder/decoder setting windows work on Vista x64.

But another thing, files encoded with v1.2.2 shows up as v1.2.1 in GSpot and MediaInfo. Is it so that the version number haven't been bumped up to v1.2.2 in the source code or could it be related to the specific softwares in question.

Anonym hat gesagt…

Hi koepi,
can we expect a xvid 1.22 VAQ-Version?

Thanks,
Olnima

Anonym hat gesagt…

por que no agregas cuda para la decodificacion de video??
gracias por el code.

Anonym hat gesagt…

Hallo Koepi,
nochmals die grosse Bitte nach einer xvid 1.22 VAQ!

Schöne Gruße,
Olnima

Anonym hat gesagt…

Could you please also handle the xvid fourcc (lowercase, not the usual XVID)?

token hat gesagt…

Under Win 95 can`t work next buttons in Xvid Configuration:
- more...(Profile and Encoding type);
- calc...;
Zone Options...;
Other Options...

Please fix this problem...

token hat gesagt…
Dieser Kommentar wurde vom Autor entfernt.
Peter Bennett hat gesagt…

Hi Koepi
When installing xvid 1.2.2 on x64 system the shortcuts for encoder properties and decoder properties are wrong. It is
C:\Windows\system32\rundll32.exe xvidvfw.dll,Configure
It should be
C:\Windows\sysWOW64\rundll32.exe xvidvfw.dll,Configure
I changed them in the shortcut and the properties work.
If you make a change to your install and you don't have an x64 system I can test it for you.

Anonym hat gesagt…

Any news when we will see a VAQ patched v1.2.2 Xvid from you Koepi?

Anonym hat gesagt…

Hi Koepi, I wasn't sure how else to contact you, other than this blog. The link to doom9 needs to be updated to .net, instead of .org.

gooogleable hat gesagt…

How do I use the Xvid codec without really installing it?

----------

My uni doesn't allow me to install Virtual Dub or the Xvid codec. I got vdub to work anyhow by just putting every DLL into vdubs directory.

So i wondered if there was a similar solution to my Xvid problem?

Is there a way to put all necessary files for the Xvid codec somewhere where Vdub can find them, which doesn't involve installing, or accessing system folders etc.?
Thanks!

I guess that in general my question is:

How do i make Virtualdub as portable as possible? (without using VirtualdubPortable, cos that one seems infected with spyware.)

Also, if anyone knows a codec which works with WMV under Linux/Ubuntu, i'd really like to know ...

Koepi hat gesagt…

Ooops - will fix the link to Doom9 ASAP, thanks for the hint!

As for VirtualDub "Portable" - I have no clue and no time to try myself, just ask Google. That problem might already be solved by others!

Cheers
Koepi

Anonym hat gesagt…

Hello.

I have a file that seems to be encoded with XviD, but when decoding with XviD, picture has some garbage in lower part of frame. When decoding with libavcodec everything is fine. I uploaded zip with clip and screenshots showing difference in decoding on sendspace http://www.sendspace.com/file/3wqxw0 . Could you please take a look.

Kevin Right hat gesagt…


Great post! Thanks a lot for sharing with us.
Kevin Right